Fix Bug

Falha na conexão WIFI no Dell I7560 com Linux Mint 19.3

Primeiramente, gostaria de deixar claro que todos os comandos postados e utilizados aqui, serviram de solução para o meu caso. Qualquer replicação utilizada com o conteúdo aqui fornecido é de responsabilidade sua, assim assumindo os riscos em caso de falha.

Estou escrevendo sobre isso porque realmente tem muito pouco post falando sobre essa falha de conexão que sofria desde o utilizava o Windows 10.

Eu utilizo o sistema operacional Linux Mint a um pouco mais de 1 ano e desde então venho me adaptando muito bem. Mas um grande problema me perseguiu durante esse período. A placa de Rede Wireless, não permanecia conectada por muito tempo, e de tempos em tempos eu era obrigado a reiniciar o notebook após utilizar durante um período curto de tempo.

Essa semana, decidi aproveitar meu tempo para mudar de sistema operacional, talvez um Ubuntu puro ou algum outro O.S que me atendesse um pouco melhor tentando resolver esse problema.

Antes de iniciar o processo para reinstalar outro S.O, decidi pesquisar um pouco mais e consegui encontrar a solução em blog que menciono mais embaixo e executei os seguintes passos:

cat /etc/*release |head

cat: /etc/upstream-release: Is a directory
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=19.3
DISTRIB_CODENAME=tricia
DISTRIB_DESCRIPTION=”Linux Mint 19.3 Tricia”
NAME=”Linux Mint”
VERSION=”19.3 (Tricia)”
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME=”Linux Mint 19.3″
VERSION_ID=”19.3″

Verifiquei se minha versão do Kernel é igual ou superior a 4.5.0.

uname -r

5.3.0-28-generic

Verifiquei também o Driver da minha placa de rede com o comando:

lspci |grep Wireless

02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

Após isso, segui os passos do post desse site: http://infocotidiano.com.br/2016/06/resolvendo-problemas-com-wireless.html

sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/
sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null
sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/board-2.bin?raw=true
sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true
sudo chmod +x /lib/firmware/ath10k/QCA6174/hw3.0/* 

Reiniciei o computador, e a Placa Wi-fi ficou mais estável do que nunca!!

Fonte: http://infocotidiano.com.br/2016/06/resolvendo-problemas-com-wireless.html

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *